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1. Instruction 
 

1.1  About the EISC-Studio3 
 

EISC-Studio3 is an integrated development environment for the developers who are using EISC 

CPU in Windows environment. EISC-Studio2 consists of many properties that utilize the 

important features of EISC CPU best.  

 

Feature 

 Integrated Development Environment (IDE)  

– Works in Windows 9x/ME/NT4/2000/XP/VISTA 

– Friendly User Interface like MS Visual-Studio  

– Source Edit/Compile  

– Automatic Windows docking  

– Project file Tree view  

– Class / Function / Global variable Tree view  

– Auto Generate Makefile  

– Graphical Symbol Browser  

– Support All EISC compilers  

 

 Convenient Embedded Editor  

– Syntax highlighting  

– Column Editor 

– Code Completion  

– Smart Auto-indent  

– Find and replace facilities  

– Bookmark  

– Move Up/Down Current Line 

– Support for collapsible nodes (outlining)  

– Supports various fonts and styles  

– Macro record/play 

 

1.2  About the Handbook 
 

This manual has been prepared for the users who use EISC-Studio3. To get more information on 

programming, refer to a reference book called EISC software user guide. 

 

This handbook consists of the following contents. 

 

 Installation: How to install EISC-Studio3 

 Programs: Basic things to know to make a program 

 Overview: EISC-Studio3‟s overall constitution and functions 

 Working with an Editor: Functions and usage of EISC-Studio3 editor 

 Projects: Creating and using a project 

 Build: Compiling and building with EISC-Studio3 

 Debug: Using EISC-Studio3 debugger 

 Tool: Using special tools of EISC-Studio3 

 Sample Program  
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2. Installation 
 

2.1  EISC-Studio3 
 

EISC-Studio3 is available on ADChips‟s website (http://www.adc.co.kr) or provided CD. 

 

2.2  Requirements 
 

 Over Windows 2000 OS version. Windows NT series(NT/2000/XP/VISTA) are recommended. 

 Refer to EISC-Studio3 Installation Manual to install the EISC-Studio3 program. 

 

2.3  Starting EISC-Studio3 
 

Execute the EISC-Studio3 program. 

(Ex: C:\Program Files\ADChips\EISC Studio 3\ES3.exe) 

 

 
 

[Figure 2-1] Path of EISC-Studio3 program 

 

 

http://www.adc.co.kr/
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3. Programs 
 

Once installing and starting EISC-Studio3 successfully, user needs to know what kinds of files are 

necessary for compilation of each core and what kinds of files are created after compilation. 

 

3.1  Base files to be included in a project 
 

 crt0.S: Initialization, data area copy, global variable initialization and system register set up. 

– Since the crt0.S is provided according to an EISC-core and board, user can add or 

modify functions of the file. 

 

 Linker Script: Memory area setup and stack point setup. 

– The linker script is also provided in the form of core-name.vct(se3208.vct, ae32000.vct 

and so on) or core-name.x. User can add or modify this file as necessary. 

 

 

3.2  Make and Makefile 
 

After create a project, a “Makefile.e” file is created for Make. 

EISC-Stuio3 creates execution file by using the Makefile.e. For a quick explanation about 

Makefile, refer to a S/W developer guide. 

 

3.3  Executable file (elf) 
 

When user creates a project through EISC-Studio3, an output file format is ELF(Executable and 

Linkable Format) file. This manual does not discuss about the ELF file format. 

 

3.4  Verifying Compiler Installation 
 

To using EISC-Studio3 correctly, user has to verify an installation s/w tool-chain(compilers, 

assembler, linker and so on) whether programs are installed right path or not. A path of the s/w 

tool-chain installed is in the EISC-Studio3‟s installed directory. For example, if the EISC-Studio3 

is installed to “C:\ProgramFiles\ADChips”, the s/w tool-chain is located at 

“C:\ProgramFiles\ADChips\EISC Studio 3/local” directory. The s/w tool-chain programs which in 

the path are executed as the highest priority. 

After checking the path and executing EISC-Stuio3, next step is Enjoy the program! 
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4. Overview 
 
In EISC-Studi3, user interfaces are divided into the following categories for user convenience. 

- Project Explorer Window, Tags View Window, Text Editor Window, Output window, Menu Bar, 

Tool Bar, Status Bar.  

In the following section, the functions and features of each window will be discussed in more detail. 

 

4.1  Project Explorer Window 
 

Project Explorer window shows source files, 

header files, linker script, additional files not 

compiled and static library files. 

 

User can add exist file or new file by placing 

a mouse curser on each files‟ category and then 

clicking right mouse button. After that an “Add 

Exist Files” menu and a “Add New File” menu 

are popped and user can select one. 

 

The “Add Exist Files” menu adds a already 

implemented file to this project and “Add New 

File” menu adds a new empty file. 

 

By double clicking file name or pressing 

enter key after select file, user can open Text 

Editor Window and can see the source file. 

 

 

 

 

 

 

 

 

                                                   

  

 

 

[Figure 4-1] Project Tree 

 

          : Sorts files in current project by compile or alphabet order. 

 

 

: Shows “Project Properties” dialog. User can set or modify options of a current project. 

Chapter 6 shows more details about the dialog. 
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4.2  Tags View 
 

Tag Vies window shows functions, variables, typedef, and macros which are defined in current 

project. 

 

Double-clicking a function or a variable, which 

users want to see, makes a corresponding file 

activated in Text Editor Window and move 

cursor to a corresponding line. 

 

The Tags View window is refreshed whenever 

users save a file. 

 

 

 

 

 

 

 

 

 

 

[Figure 4-2] Tags View Window 

 

 

4.3  Text Editor Window 
 

The Text View Window is a window in which users can open as many files as wants to open. Also, 

through this window, user can read, write and modify the source code. 

 

To make editing easy, reserved words, comment and character streams are shown with different 

colors and font in this window. Chapter 5. Working with the Editor explains the window more 

details. 

 

 
 

[Figure 4-3] Text View Window 
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4.4  Output View Window 
 

The Output View window is composed of  Output View와 Find(1) View and CSCOPE Result 

View. 

 

 
 

[Figure 4-4] Output View 

 

 

 Output View: Shows commands during compile, error messages and source lines that 

contain errors. If user double clicks the source line, cursor will move to the corresponding 

line of the cord. 

–    :  (Goto Previous Error Line),  (Goto Next Error Line), Speed key F4 

 

–       : Save All Message as file (Creates a build_log.txt file in a project folder) 

 

–       : Clear All Message   

 

  
 

[Figure 4-5] Find(1) View 

 

 Find(1) View: Shows result of “Find”, “Replace” and “Find in Files” actions. If user clicks 

the result, cursor will move to the corresponding line of the cord. 
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 [Figure 4-6] CSCOPE Result View 

 

 CSCOPE Result View: Shows results of CSCOPE menu action. Chapter 8 discusses about 

the CSCOPE more detail. 

 

 

4.5  Menu Bar 
 

In this section, a property of each menu will be explained.  

 

 

4.5.1 File 

File menu is used to create, open save and print files and projects. 

 

 New 

-  Files (Ctrl+N,     ): Creates a new file. 
 

-  Project: Creates a new project. 

 

 Open Files (Ctrl+O,     ): Opens a file. 

 

 Close  

-  Close a file in Text Editor Window. 

 

 Close All 

-  Close all activated files in Text Editor window. 

 
 Save (Ctrl+S,     ) 

-  Save a file that is activated in Text Editor window. 

 
 Save As  

-  Save an activated file in Text Editor window with another name. 

 
 Save All  

-  Save all activated files in Text Editor window. 

 
 Open Project (Ctrl+Shift+O) 

-  Open a project. 

 

 Save Project 

- Save an activated project. 

 

 Close Project 

-  Close an activated project. 



 

       17 

 

 

 EISC-Studio3 Manual 

 Print (Ctrl+P,     ) 

- Print a source file activated in Text Editor window. File name, date/time, 

page, and ADChips‟s website address are printed on header and footer. 

 
 Page Setup 

- Set up paper size, orientation and paper margin for printing. 

 

 Recent Files  

- Show list of files that have been opened recently and if user selects a file, user 

can see the file in Text Editor Window. 

 
 Exit  

-  Exit the EISC-Studio3 program. 

 

4.5.2 Edit 

Edit menu is used to edit a source code in Text Editor Window. Cut, Copy, Paste, Do, 

Undo, Match Brace, Complete word, Block comment/uncomment, Increase/Decrease 

Indentation, Line Number and Zoom functions are included in the Edit menu. Also, the 

menu includes a Search faculty. 

 

 
4.5.3 View 

User can activate specific windows by using this menu. In addition to, the View menu 

determines EISC-Studio3 theme and sets Toolbars. 

 

 Navigate Backward (Ctrl+Left Arrow,     ): Returns to a location before a 

command action Goto definition. 

  

 Navigate Forward (Ctrl+Right Arrow,     ): Locates a cursor to a target of 

command Goto definition. 

 

 Start Page: Shows Recent Project window. User can execute Create New Project 

and Open Other Project. 

 

 cscope: Go to the CSCOPE Result view window. 

 

4.5.4 Project 

With the project menu, user can add a new file, add an exist file and configure properties 

of a currently activated project. 

 

4.5.5 Build 

Creates an executable file, a binary file and a result file of disassembling the executable 

file. Additionally, through this menu, user can re-create a Makefile and get rid of object 

files. If user checks a Full Build Message sub-menu, the output view window shows all 

of compiling and building commands. 

 

4.5.6 Tools 

User can record a Macro for special action to edit a source code. Also, user can configure 

an edit window environment such as a font, a color, etc. The CSCOPE action is included 

in the Tools menu. 
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4.5.7 Windows 

Decides a Text Editor windows‟ arrangement. 

 

4.6  Tool Bar 

 
User can add/delete icons to each Toolbar.  

 

 
 

[Figure 4-7] Tool Bar  

 

User can add/delete icons to selected toolbar by clicking a right-side button of each toolbar. A 

[Figure 4-7] shows an example method of selecting build icons. A submenu „Customize‟ in View 

menu lets user modify the icons to display. 

 

 

 
 

[Figure 4-8] Customize 

 

 Customize 

– Toolbars tab: Set up a display of Toolbars 

– Commands tab: By drag and drop a command icon, user can attach the icon to Toolbar.  

– Keyboard tab: Set up a speed key of each command. 

– Options tab: Set up a size of the icon and Toolbar Tip. 
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4.6.1 Standard Toolbar 

File create, open, save and print. 

 

 
 

[Figure 4-9] Standard Toolbar 

 

4.6.2 Editor Toolbar 

Special actions to editing such as cut, copy, paste, etc. 

 

 
 

[Figure 4-10] Editor Toolbar 

 

4.6.3 Build Toolbar 

Build actions that are compile, build, disassemble, clean and stop building. 

 

 
 

[Figure 4-11] Build Toolbar 

 

4.6.4 Full screen Toolbar 

User can show a Text Editor window as a Full screen. 

 

   
 

[Figure 4-12] Full screen Toolbar 

 

4.6.5 View Toolbar 

User can activate a window that are tag window, project window, output window and find 

window. 

 

 

     
 

[Figure 4-13] View Toolbar 

 

4.6.6 Debug Toolbar 

User can start source level debugging. 

 

     
 

[Figure 4-14] Debug Toolbar 
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4.7  Status Bar 
 

The status bar is located at a bottom of the EISC-Studio3 program. The bar displays a simple 

ability of selected menu, line number and column number. 
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5. Working with the Editor 
 

EISC-Studio3 has following editor functions. 

 

 Line control 

 Syntax highlighting 

 Column Editor 

 Find and replace facilities 

 Code Completion 

 Smart Auto-indent 

 Bookmark 

 Support for collapsible nodes (outlining) 

 Macro record/play 

  

5.1  Line Cut  
 

Cut a line currently in which cursor located and store to memory. User can paste the line to any 

place. 

 Execution: Edit -> Line Cut, Ctrl+L 

 

5.2  Line Delete  
 

Delete a line. 

 실행: Edit -> Line Delete, Ctrl+Shift+L 

 

5.3  Goto Line  
 

Go to a specific line in activated window. [Figure 5-1] shows a dialog and user can insert a line 

number to go into the text edit-box. After that if user press “OK” button, a cursor will go to the 

appropriate line. Also, the dialog shows a total line of the activated window. 

 Execution: Edit -> Goto Line, Ctrl+G 

 

 

 

 
 

 

 

 

    [Figure 5-1] Goto Line 

 

5.4  Goto Matching Brace (Ctrl+)) 
 

As a [Figure 5-2], the text editor highlight two matched brace. After locates a cursor to a brace, 

user can go to a matched brace by executing the command “Goto Matching Brace”. 

 Execution: Edit -> Goto Matching Brace, Ctrl+] 
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[Figure 5-2] Goto Matching Brace 
 

5.5  Column Editor 
 

This editor function can insert or modify multiple lines. In order to select multiple lines, user 

should press Alt key and mouse left button simultaneously and then drag. Another way to select is 

press Shift+Alt key together and press arrow keys. 

 

  Execution: Edit -> Column Editor, Alt+C 

 

                          
 

   [Figure 5-3] Column Editor 

 

5.6  Find 
 

The Find menu can be used only in selected file. 

 

① From the Edit Menu, select the Find or using speed key “Ctrl + F” or press a icon      . 

② After step ① user can see a dialog like as [Figure 5-4]. User can insert a text pattern to 

“Find what” text edit-box.  

③ After press “Find” button, EISC-Studio3 finds the text pattern from current cursor position 

to bottom. If matched text found, the text is shown with inversion. 

 

 
 

[Figure 5-4] Find 

 

※ A Transparent function can show a text behind the Dialog Box 

 
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 Match whole word only  

– Find a text pattern, exactly matched with “Find What”. 

 Match case  

– Find a text pattern with case sensitive.  

 Regular Expression  

– User can use regular expressions. 

 Wrap around 

– Find a text pattern by search in a cycle. 

 Direction 

– Decide a search direction up or down. 

 

5.7  Find Next/Previous 
 

After finding the text pattern, user can move to next or previous matched text. 

 Execution: Edit -> Find Next, F3 

 Execution: Edit -> Find Previous, Shift+F3 

 

5.8  Find in Files 
 

This menu is used to the same pattern in a selected directory. 

① From the Edit Menu, select the “Find in File” or using speed key “Ctrl + Shift + F”. 

② As a [Figure 5-5], user can insert a text pattern to search into a “Text to search for” edit box 

and select scope. 

A. Project files: Search in currently activated project. 

B. Search path (below): Search in user selected directory. 

- Path: Select a search path 

- Mask: Select a file type to find. 

③ User can see a result of the find through Find View window like as [Figure 5-6] 

④ Double-clinking the result search line on the Find View window, cursor will move to the 

corresponding line. 

 
 

[Figure 5-5] Find in Files 
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 Options 

- Whole word: Find a text pattern with exactly matched. 

- Match case: Find a text pattern with case sensitive.   

- Regular Expression: User can use regular expression. 

 
 Scope 

- Project files: Search the whole files activated in current project. 

- Search path(below): Set a user defined path to find. 

 

 
 

[Figure 5-6] Find(1) View 

 

5.9  Replace 
 

Replace menu can be used only in selected file. 

 

① Form the Edit menu, select “Replace” menu or press “Ctrl+H”. 

② After step ① user can see a dialog like as [Figure 5-7]. To replace text, user should insert a 

text pattern that you want to find to “Find What” and insert a replace text to “Replace with” 

text edit box. 

③ Clink on the “Find Next” button to search for and click on the “Replace” button to replace. 

Using “Replace All” button, user can do both the “Find” and “Replace” at the same time.  

 

             
 

  [Figure 5-7] Replace Text 

 

※ A Transparent function can show a text behind the Dialog Box 

 

Options of the Replace dialog are same as the Find dialog‟s. 
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5.10 Duplicate Current Line 
 

Copy a line and insert the line immediately to current location. 

 Execution: Edit -> Duplicate Current Line, Ctrl+D 

 

 
 

 [Figure 5-8] Duplicate Current Line 

 

5.11 Complete Word 
 

EISC-Studio3 supports powerful edit functionalities. Making complete word is one of that. As the 

[Figure 5-9], whenever user types characters, EISC-Studio3 shows words list matched with the 

characters. To make complete word, user just selects a word in the shown words list. If EISC-

Studio3 finds only one matched word, completes the word automatically. EISC-Stuio3 finds 

matched words by searching on a current working file and project‟s tag view. 

  Execution: Edit -> Complete Word, Ctrl+Space 

 

 
  

  [Figure 5-9] Complete Word 

 

5.12 Bookmark 
 

– Toggle Bookmark, (Ctrl+F2,    ) 

Create bookmark to a source line like as [Figure 5-10] or if there have been created 

bookmark, removes that. 

 

– Next Bookmark, (F2,     ) : Go to next bookmark 

 
– Previous Bookmark, (Shift+F2,     ) : Go to previous bookmark 

 
– Clear All Bookmark, (    ) : Get rid of all of the bookmarks on Text Edit Window. 

    
[Figure 5-10] Bookmark 
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5.13 Indentation 
 

 Increase Indentation (    ) 

Increase an indentation at current cursor location. 

 

 Decrease Indentation (    ) 

Decrease an indentation at current cursor location. 

 

 

5.14 Move Up/Down Current Line 
 

 Move current source line up or down 

Execution: Edit -> Move up Current Line, Ctrl+Shift+Up Arrow 

Execution: Edit -> Move down Current Line, Ctrl+Shift+Down Arrow 

 

5.15 Change Case 
 

 Upper Case 

Change selected English characters to upper case. 

 

 Lower Case 

. Change selected English characters to lower case. 

 

 

5.16 Comment 
 

 Block Comment/Uncomment (    ) 

 

– Block Comment  

After selecting source code as a block, the Block comment operation inserts “//” at front 

of each line like as [Figure 5-11]. 

 

– Block Uncomment  

Remove “Block Comment”. 

 

                          
 

[Figure 5-11] Block Comment 

 

 Stream Comment 

After selecting source code as a block, the Block comment operation inserts “/* */” at 

front and last of the block like as [Figure 5-12]. 

 

   
 

[Figure 5-12] Stream Comment 

  
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5.17 View Menu 
 

 Show White Space and Tab 

Text Editor window shows white space. „Tab‟ character is shown as „‟ and black is shown 

as „.‟. 

 

 

       
 

[Figure 5-13] Show White Space and Tab 

 

 Show End of Line  

Show end of line as „CR‟(DOS mode) and „LF‟. 

 

          

 

 

 

 

 

 

 

 

 

 

 

 

[Figure 5-14] Show End of Line 

 

 Show Indent Guide 

Show a line between matching brace and indentations. 

 

              
 

[Figure 5-15] Show Indent Guide 

 

  
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 Zooming 

Only applied to activate source in Text Editor window. In some cases, zooming has to be 

done in many steps depending on the property of each font. 

 

– Zoom In 

Execution: Ctrl + Mouse wheel up. 

– Zoom Out 

Execution: Ctrl + Mouse wheel down. 

 

 

 Folding 

 

This function is usually used to make handling a large source code easy. The folding hides 

unnecessary block to programming. 

 

If user copy or paste the Folded block code, the block would be unfold. 

 

- Fold All  

Fold all of folding points.  

 

 

   
 

[Figure 5-16] Fold All 

 

- Collapse the current level   

Fold a current working block. By clicking Folding point as a [Figure 5-17], user can fold or 

unfold the block. If user clicks the Folding point within pressing Ctrl key, all of sub blocks 

are folded. 

 

 

 
 

[Figure 5-17] Collapse the current level 

 

- Uncollapse the current level 

Unfold a current working block. By clicking Folding point as a [Figure 5-18], user can 

unfold the block. If user clicks the Folding point within pressing Ctrl key, all of sub blocks 

are unfolded 
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[Figure 5-18] Uncollapse the current level 

 

 

- Unfold All 

Unfold all of folding points 

 

- Hide Lines 

User can hide a specific line. After the Hide Lines command, text editor window shows 

specific sign like as right side of [Figure 5-19]. If user wants to disable the hide line, just 

click the specific sign. 

 

 

 

            
 

  [Figure 5-19] Hide Lines 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  
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6. Project 
 

The basic things that user needs to know about generating and managing a project in EISC-Studio4 are 

as follows. 

 

•  Files consisting of a project 

-  *.epx: This is a project file. Thus, be careful not to delete this file. 

-  Makefile.e: This is a Makefile used in EISC-Studio3. 

 

•  Compatibility to the old version 

A project generated by previous version of EISC-Studio can used in EISC-Studio3 without any 

modifications. However, user needs to use the “File  Open  Project” menu to open the project. 

When user opens the old project, EISC-Stuio3 changes a format of the project and can be used by 

EISC-Studio3. User can see a new file *.epx that is newly created project file for EISC-Studio3. 

 

6.1  Create new Project 
 

① From the menu, executes File  New  Project menu or click “Create New Project” button 

from the Start Page. As a [Figure 6-1], user can select a project type.  

– EISC General.dll: Create general application (empty project) for EISC processor. 

– Sample Project.dll: Create sample project to print “Hello World” string. 

 

 
 

  [Figure 6-1] Project Type 

 

② [Figure 6-2] shows “General EISC Project” Dialog and user can set several options to make 

project. 
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[Figure 6-2] General EISC Project 

 

 CPU Type 

Select EISC CPU Type. 

 

 Build Type 

– Executable: Create “*.elf” executable file as an output. 

– Static Library: Create “*.a” static library as an output. 

– Dynamic Library: Create “*.so” dynamic Library. 

 

 Project Name 

Determines the project name. 

 

 Make New Project Folder 

If user checks “Make New Project Folder”, EISC-Studio3 create a folder as same name as 

“Project Name” to “Project Directory”. 

 

 Project Directory 

Determines a directory to create the project. 

   

 

 

 

6.2  Open Project & Close Project 

 
When a project is being opened, user needs to close the project in order to generate a new project. 

 

 Open Project & Close Project 

① Executes File  Close Project menu 

② When a message window asking whether user wants to save the project is popped up, 

click the “OK” button and close the project. 

③ Execute File  Open Project menu 

④ When the “Open” dialog is popped up, select a “ *.epx “ project file. 

 

 Startup Page 

① Start the EISC-Stuio3 

② Select a project file from the “Resent Project” list in the StartupPage as shown on 

[Figure 6-3]. 
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③ If user cannot find a project in the “Resent Project” list, then click on the “Open Other 

Project”. 

⑤ When the “Open” dialog is popped up, select a “ *.epx “ project file. 

 

 
 

[Figure 6-3] Startup Page 

 

 

 

6.3  Add and Remove files 
 

User can add or remove files only after generating a new project or opening a project. 

All the files in a project are classified into Source Files, Header Files, Linker Script File, No 

Compile Files, and Static Library Files. 

 
There are two ways to add or remove files to or from a project. 

 Adding Files 

① Depending on the file type that will be added to the Project Explorer window, click on 

one of the file types (i.e., Source Files, Header Files, Linker Script, No Compile Files, 

Static Library Files). 

(※ EISC-Studio3 classifies automatically only .c, .s and .h files, so user does not 

need to add files according to the type) 

 

② Click on the right mouse button and select “Add Exist File” or “Add New File“ menu. 

– Add Exist File: Add an exist file 

– Add New File: Add a new file 

 

③ If user select “Add Exist File” menu, user can see a dialog shown on [Figure 6-4], and 

can select and add a file.  
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[Figure 6-4] Add Exist File 

 

If user select “Add New File”, user can see a dialog shown as [Figure 6-5], and can fill 

the text boxes up to add a file. 

 
 

[Figure 6-5] Add New File 

 

An alternative way to add a file is executing a Project  Add Exist File/Add New File 

menu. 

 
 Removing Files 

 

This menu is used to remove a file that is not necessary to manage a project. To remove a 

file, select a file on Project Explorer window and press Delete key. Also, user can remove a 

file using mouse right click and select “Remove” menu. 

 

 

6.4  Properties  
 

 General Properties ( ) 

 

Project properties shown as [Figure 6-6], user can see and modify a general information of a 

project. The information in the inactivated fields cannot be modified. By selecting each field, 

user can see the additional information on the corresponding field.  
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[Figure 6-6] Project Properties (General Properties) 

 

－ Project Name 

Project Name activated. 

 

－ Project Directory 

A path of project created. 

 

－ Build Type 

Build Type of the project. 

 

－ Output File Name 

This shows file name that has been generated when user build a project. 

 

－ Project Object Directory 

This shows a relative path of object files generated. 

 

－ Project Output Directory 

This shows a relative path of project directory in which files (*.elf, *.bin) generated. 

 

－ Last Saved Time 

This shows a time when a project is saved last. 

 

 Files 

 

A files menu of the Project Properties dialog shown as [Figure 6-7] shows files‟ name and 

static library files. The list of the files is shown with a relative path. 
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[Figure 6-7] Project Properties (Files) 

 

Order of compilation is added order to the project. Sometime, error occurred when a crt0.S 

is not compiled at first. Due to this reason, user had better put the crt0.S file to top. 

 

① Execute Project  Properties menu 

② Select FilesSource Files. 

③ Select a file and by clicking  or  , user can move up/down the compilation 

order. 

④ After confirm, user can recognize the order is changed on Project Explorer window. 

 

 

 Directory 

 

In the Project Settings dialog shown in [Figure 6-8], user can set up Include, Library 

directories. The following icons are used to add or delete the directory. 
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[Figure 6-8] Project Properties (Directory) 

 

- Include Directory 

This menu does the same function as user uses the “-I” option when compiling gcc. It 

is used to add the Include path. 

 

- Library Directory 

This menu does the same function as user uses the “-L” option when compiling gcc. It 

is used to set up a user library path. 

 

 

 : Add a directory 

 

        : Delete a directory 

 

 : Change an order of added directory 

 

 

 Build Options 

In the Project Settings dialog shown in [Figure 6-9], user can see the general options that 

can be used to build a project. 

 
- Tool Chain Settings 

C compiler, C++ compiler, Assembler, LD and AR program setting. 
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    [그림 6-9] Project Properties (Build Options-> Tool Chain Settings) 

 

- Tool chain Flags 

User can set one of True/False for frequently used options and insert additional options 

to text box. At a bottom of the dialog, user can see a simple explanation of each option. 

For more information on compilation option, user can refer to GCC manual. 

 

 
 

[Figure 6-9] Project Properties (Build Options-> Tool chain Flags) 

 

- Event After Link 

After build a project, user can see an event. At a bottom of the dialog, user can see a 

simple explanation of each option. 
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[Figure 6-9] Project Properties (Build Options-> Event After Link) 

 

Ex) command : copy $(TargetPath) ../ 

Copy an output file(.elf) to upper directory. 
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7. Build 
 

Most functions regarding the Build menu are easily accessible by clicking corresponding icons in the 

Build Toolbar. In this section, only a simple explanation for each menu will be given. For more 

information on this section, refer to a reference book, EISC Software Developer‟s Guide. 

 

 Build  Build Project, F7,       

Creates *.elf and binary files.  

 

 Build  Compile File, Ctrl+F7,       

Compiles a file that is active in the Text Editor window. 

 

 Build  Rebuild Project, Ctrl+F8 

Removes all of created object files and build again. 

 

 Build  Clean All,       

Removes executable file and object files. 

   

 Build  Stop the Build,       

Stops a current build process. 

 

 Build  Disassemble file,       

Creates disassemble file of the elf file. 

 

 Build  Full Build Message 

Shows full build message on Output window.  
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8. Debug 
To use source level debugging, user must insert “-g” option to compile option. Compiler inserts 

debugging information to object file and elf when compiler compiles sources with the “-g” option. 

The debugging information does not affect a binary file size but the output executable file size will be 

bigger. The “-g” option is useful to find errors and bugs. 

 

 

8.1  Target of Debugger 
 

 Simulation 

Like simulating a program in a target environment in PC, simulation is a way of debugging a 

program in a simulated environment. 

 

8.2  Starting Debugger 
 

① Open a project by FileOpen Project menu. 

② Executes DebugStart Debugger menu or “F5” or press       icon. 

 

8.3  Debug Options 
 

 As shown in [Figure 8-1], user sets up several debugging options to debugging.  

 

    
 

[Figure 8-1] Debugger Options 

 

There are three types of debugger (Insight(GUI), GDB(CLI), User Define) and additional 

argument is optional. 

 

Bottom of the dialog, the Auto-Command for Debugger option is used for frequently used 

command. A icon      can execute the commands automatically, and      icon can remove a 

selected command.  

To reorder the commands, user have to use two icons        . 
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8.4  Debugging interface 
Insight mode (GUI): Only for AE32000C architecture 

 

 
 

[Figure 8-2] Debugging Environment (Source insight) 

 

CLI mode ( Command Line Interface) 

 

 
 

[Figure 8-3] Debugging Environment (Command Window) 

 

To get more information of usage GDB, user have to visit a gdb website http://sourceware.org/gdb/. 

http://sourceware.org/gdb/
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9. Tools 
 

9.1  Macro 
To bind frequently used command to one command, the Macro tool is very useful. Also, for  

editing a source, the Macro tool can be used. 

 

        
 

[Figure 9-1] Macro 

 

 Start Recording: Records commands to make Macro 

 Stop Recording: Stop the recording 

 Playback: Executes the Macro 

 

9.2  Source Code Formatter 
 

 Format Current File 

Applies to source cord a format that is set in AStyle Options. 

 

 AStyle Options 

Sets a format of source code. 

To get more information about usage of the Astyle option, refers to  

Http://astyle.sourceforge.net/ . 

http://astyle.sourceforge.net/
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9.3  CSCOPE 
 

The CSCOPE tool is developer tool to search a source code. 

 

 Find this C symbol 

Find all of symbols in the current project source file. 

 
 

[Figure 9-2] CSCOPE Result View (1) 

 

 Find this function definition 

Find function prototype. 

 

 
 

[Figure 9-3] CSCOPE Result View (2) 

 

 Find functions called by this function 

This menu finds callee functions of the selected function. 

 

 
 

[Figure 9-4] CSCOPE Result View (3) 
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 Find functions calling by this function 

This menu finds a caller function that calls the selected function. 

 

 
 

[Figure 9-5] CSCOPE Result View (4) 

 

9.4  Options 
 

 Editor Font & Color 

User can set color to keyword, comment, etc. 

 

① Tools  Preferences menu shows a dialog shown as [Figure 9-6]. 

② User can change font and color of selected category by choosing sub-menu. 

 

 

 
 

[Figure 9-6] Option (Editor Font & Color) 

 

 Editor Global Option 

The Editor Global Option applies to Text Editor Window as the highest priority. 

 

① User can set global Text Editor environment such as font, size and ground color.  

② “Global Color” menu lets user can change color of Match Brace, Line Number, etc. 

[Figure 9-7] shows default colors of each item. 

③ “Auto Completion” menu is for whether the “Complete Word” function enable or not. 
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[Figure 9-7] Option (Editor Global Option) 

 

 

 An environment file (editorconfig.cfg) 

The environment of EISC-Stuio3 is saved as a file „editorconfig.cfg‟ to „config‟ folder in the 

installed directory. (ex> C:\Program Files\ ADChips\EISC Studio 3\config). If user deletes 

the environment file, EISC-Studio3 is set up by default when restart. Also, user can use 

another environment file by coping one. 

 

 

 Executable Directories 

Configures a compiler path used by the EISC-Studio3. In Executable Directories, a first 

defined directory is the highest priority. If user want to use own compiler, press    icon and 

sets up the compiler‟s path. 

 

 

  
 

[Figure 9-8] Option (Editor Directories) 

 

 Include Directories 

 icon let user can add an additional include directory to current project. 
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9.5  EISC Studio Command Prompt 

 
 

[Figure 9-9] Command Prompt 

 Executes a command prompt 

 

9.6  External Tools 
 

 User can execute external programs after registers the programs. 

 

 
 

[Figure 9-10] External Tools 

   

 Form the [Figure 9-10], a first text box (Command:) indicates the external program‟s name 

and the second text box (Arguments:) indicates additional arguments to execute the program. 

 [Figure 9-11] shows argument addition selection box. 

 
[Figure 9-11] Argument 
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10. Window 
 

10.1  New Window 
 

Create new Text Editor Window with same name as activated source file. 

 

 

  
 

[Figure 10-1] New Window 

 

10.2  Cascade/Tile 
 

Displays each Text Editor windows as a cascade or tile. 
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11. Help 
 

11.1 About ES3… 
 

 
 

[Figure 11-1] About EISC Studio 3 

 

Shows version of EISC Studio 3 and website of ADChips. 

 

11.2 Update Check 
 

EISC Studio3 supports Auto Upgrading through Internet. HelpUpdate Check menu executes 

ES3_AutoUpdater shown as below. 

 

 
 

[Figure 11-2] Auto Updater 

 

After press          (Check Update) button, the program tries to connect to server. 
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[Figure 11-3] Auto Updater connects to server 

 

If the program establishes a connection to Server, the program checks current version and find an 

upper version. 

 

If there is exist the upper version of EISC-Studio3, user can upgrade the program by pressing a 

button              (Update Now) after close a current project.  

  

 

       

 

 

 

 

 

     

 

 

 

 

 

 

[Figure 11-4] Auto Updater is updating the EISC-Studio3 

 

[Figure 11-4] shows update process. After update successfully, user can see “Update 

Completed…” message. 

 

Update information is shown if             (Update Info) button is pressed. 
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12. Additional Tools 
 

This chapter introduces convenient functions not explained. 

 

12.1 Location of Project Explorer Window/Output View Window 
 

User can determine the position of the Project Explorer window and Output View window by 

mouse drag. 

 

 

 
 

[Figure 12-1] Position of Project Explorer Window 
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12.2 New Horizontal Tab Group/New Vertical Tab Group 
 

Determines Text Editor Window‟s display horizontal or vertical. 

 

 
 

       

  

< New Horizontal Tab Group>               < New Vertical Tab Group> 

 

[Figure 12-2] New Horizontal Tab Group/New Vertical Tab Group 

 

12.3 Move to Next Tab Group 
  

      

 

 

 

 

 

 

 

 

[Figure 12-3] Move to Next Tab Group 
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12.4 Move to activated Text Editor Window (Ctrl+Tap, Ctrl+F6) 
 

“Ctrl+Tap” command makes user can select an activated Text Editor window. [Figure 12-4] shows 

selection box to choose a file. 

To move another file without the selection box, use a “Ctrl+F6” command. 

 

 
 

[Figure 12-4] Move to activated Text Editor Window  
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12.5 Move to Active Tool Window (Alt+F7, Alt+F6) 
 

“Alt+F7” command makes user can select an Active Tool window. [Figure 12-5] shows selection 

box to choose a window. 

To move another Active Tool window without the selection box, use a “Alt+F6” command. 

 

 

 
 

[Figure 12-5] Move to Active Tool Window 
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13. Example Program 
 

Congratulations! 

Final step is making example program with EISC-Studio3!! 

 

A sample project is automatically created when the EISC-Studio3 program install. This chapter will 

explain an execution and a debugging method. 

  

 

13.1 Create New Project 
 

① Executes “Create New Project” or File  New  Project menu of Start Page. 

② After pop up a dialog shown as [Figure 13-1], select „Sample Project.dll‟ then press “OK” 

 

 
 

[Figure 13-1] Create New Project 

 

③ Like as [Figure 13-2], fill all of text box and press Create botton. 

 

 
 

[Figure 13-2] General EISC Project 
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13.2 Completed Project 
 

We can see “HelloWorld” project shown as [Figure 13-3]. 

Already inserted necessary files to the Sample project. 

 

   
 

[Figure 13-3] Add New File/Add Exist Files 

 

13.3 Build Project 
 

Next, we can get an executable file. 

Execute a BuildBuild Project or press F7, then the Output View window shows compile and 

build messages. 

([Figure 13-4] shows a build message after check BuildFull Build Message.) 

 

Executable file „ae32000_hello.elf‟ and binary file „ae32000_hello.elf.bin‟ are created. 

 

Execution: Build  Build Project,     , F7 

 

 
 

[Figure 13-4] Build-ae32000_hello 

13.4 Debugging 
 

After build the “HeloWorld” project, we can debug the executable file as a Simulation target. 

 

① Execute DebugStart Debugger menu or press F5,      . 

② As you can see a [Figure 13-5], a Source Insight debugging program is executed (AE32000). 
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[Figure 13-5] Debugging Environment (Source Insight) 

 

③ Now start debugging. To debug the program, we can use both ways, one is use Console 

window and another is use speed icon. This section explains debugging with the Console 

window. 

1. (gdb) target sim 

 The program executes on simulator, so target is sim. 

2. (gdb) load 

 Load the executable file to GDB simulator. 

3. (gdb) break main 

 Set a breakpoint to „main‟ 

4. (gdb) run 

 Execute the program until gdb meets SIGTRAP. 

 Debugger will stop at a first line of the „main‟ function. 

5. (gdb) step 

 Executes one source line. 

 

 

 

 
 

[Figure 13-6] Debugging Start 
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④ [Figure 13-7] shows debugging process. 

In a source window, 

is debugging Toolbar. User can see simple explanation 

through mouse over the each icon. 

 

is icons to show register, memory, etc, like as [Figure 13-7]. 

 

 

 
 

[Figure 13-7] Debugging 

 

⑤ The main.c program 

This example program uses a „printf‟ function. The function displays string to Console 

window. The output executable file is for AE32000 core and a start point of the file is 

reset_start defined in crt0.s file. 

 

 

 

 

 

 

 


